Серьезной проблемой у разработчиков приложения для OS Android, была фрагментация при различных разрешениях экрана. Сейчас, благодаря новой разработке Google, эта проблема должна быть исчерпана. Для этого Google выпустила специализированную библиотеку программ  Android Compatibility Package. Она доступна для скачивания всем, кто желает ею пользоваться.

Еще ранее было объявлено о выпуске Fragments API, которая предназначалась для Android 3.0. Этот новый интерфейс для разработчиков приложений API, автоматически масштабирует приложения под размер экрана устройства, которое используется. Таким образом программистам не надо было бы выпускать несколько клонов одного и того же приложения из-за разных размеров экранов в устройствах.

Главный недостаток Fragments API являлось то, что он не был совместим с версиями OS  Android моложе 3.0. Теперь же эта возможность использования API уже доступна и для пользователей с версиями ОS Adroid 1.6 и выше.

Это очень актуально, на фоне резкого скачка числа устройств с Android системами. Ожидается, что 2011 год станет также годом Android и, кроме смартфонов, на рынок хлынет огромная  волна планшетов.

Установить новую библиотеку можно используя стандартное средство обновления SDK.